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635/600 Hardware Flash Load Procedure 
This procedure describes How to Load Flash for 635-Model and 600-Model Controllers. 

 
SECTIONS IN THIS GUIDE 

Part-1 Prerequisites and Assumptions 

Part-2 Identify ‘Required Flash Version’, ‘Starting Flash Version’, and CPU-models  

Part-3 Loading Flash to the Controller (3 possible methods) 

Method-A = Load Flash from the GCS Loader Utility (600 / 635 CPUs)  

Method-B = Load Flash from the 635-CPU Webpage (635 CPUs only)  

Method-C = Load Flash from the Factory Test Station (600 / 635 CPUs) 

Flash Upgrade Charts (stepping-up flash from older systems) 
 
 
 
 

Part 1 – Prerequisites and Assumptions (required) 
 

1. 635/600 Hardware is correctly installed, boards are configured, and powered on. 
 

2. System Galaxy (SG) software has been installed (or upgraded) 

• See the SG Installation Procedure QRS (PDF) for installing System Galaxy. 
 

3. All Galaxy hardware has been added to the SG software programming screens (i.e. clusters, controllers, daughter 
boards, remote RS-485 Door Modules, etc.). 

• See the SG Software User Guide (PDF) for adding hardware to System Galaxy. 
Chapters 5, 8, and 9 cover hardware programming. 

 
4. All controllers must be connected to the GCS Event Service. 

• You can use the View > Loop/Cluster Diagnostics screen to determine if all panels are connected on each 
cluster. 

» Execute a ‘Get Controller Info’ command on each Cluster to list all programmed panels. 
» Red panels = not connected. 

 

http://www.galaxysys.com/sghelp/_docs/currdocs/QRS-QRG/SG-SystemInstallProcedure.pdf
http://www.galaxysys.com/sghelp/_docs/currdocs/SG-SoftwareUserGuide.pdf
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Part 2 – Identify the ‘Required Flash Version’ and ‘Starting Flash Version’ 
 
 The lowest CPU Model # (600 vs 635) will dictate the required flash version for all panels in that cluster. 

 
IDENTIFYING THE ‘REQUIRED FLASH’ FOR THE SOFTWARE 

 
1. Identify the Required Flash Version that should be running for each Cluster … 

 
a) From the SG menu, open the Help>About System Galaxy screen (see table below for notes). 

b)  Locate the required flash for each CPU-model based on Cluster Type (i.e., all 635s, all 600s, or mixed). 

Table-1 : Finding Required Flash Versions 

 
 
 
 
 
 
 
 
 

IDENTIFYING THE MODEL AND FLASH VERSION OF EXISTING PANELS 

2. Identify the Model # and current starting flash version for all existing controllers on each cluster. 
This will help you determine whether you have a mixed cluster. 

 
a) You must send a [Get Controller Info] command from the GCS Loader screen (or Loop Diagnostics screen). 

b) Determine whether you have a mixed cluster, or if the cluster is “all 635- model“ or all “600-model” panels. 
 

Table-2 : Finding Model# and Starting Flash Version on each controller 
 

Screen How to open screen Send Command Information Displayed … 
Loop Diagnostics from SG menu, select 

View>Loop Diagnostics 
Select ‘Get Controller Info’ 
and click [Execute] button 

Screen lists controllers with model and 
flash version. Offline panels are red. 

GCS Loader Utility 
EZ80 Tab 

Hardware Tree: 
Right-click Cluster icon 
and choose ‘Load’. 
Then select the EZ80 tab. 

Click [Get Controller Info] 
button 

The bottom text box shows a list of panels 
(model and flash version). Use scrollbar to 
see each one. Offline panels are not listed. 

 
IDENTIFYING THE NEED TO STEP-UP FLASH 

3. For panels with older flash, you can use the Flash Upgrade Charts in this guide to determine if you need to step-up flash 
to an interim version before coming up to the Required Version. 

 

Cluster Type: Controller Models: Required Flash Version: 
635 Cluster all 635-models (no 600 panels) 635 Flash version   

Use the flash file whose name indicates it is for “635_vNN.N.N” 

600 Cluster all 600-models (no 635 panels) 600 Flash version   (use the file marked for 600-CPUs) 
(for SG 11 or higher, the max. possible version is “600_v10.5.6” flash) 

Mixed Cluster 
600 & 635 

mixed 600 and 635 models 600 Flash version   (use the file that indicates 600-CPUs) 
* For SG v11 or higher, you must load the “600_v10.5.6” flash file. 

635 Flash version   (use the file that indicates 635-CPUs) 
* For SG 11 or higher, you must load the “635_v10.5.6” flash) 
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Upgrade Notice: see the Flash Upgrade Tables to determine which stepped interim flash version to load, as needed. 

 

Part 3 - Loading Flash to the Controllers 
 

 Method-A: Update Flash from the GCS Loader Utility (600 or 635 model panels) 
 Method-B: Update Flash from the 635 CPU Webpage (635 panels only) 
 Method-C: Update Flash from a Factory Test Station (FTS – all models) 

 
 
Method A - Update Flash from the GCS Loader Utility (600 & 635) 

 
 Offline panels cannot be flashed with this method. 

 Every time you flash a CPU Board, you must update all the daughter boards (manually initiated). 

 If you have a DSI-Board with remote 635-DRM Door Modules, you must allow the DRMs to update. All remote DRMs 
automatically start updating flash after the parent DSI has finished flashing. Boards update in random sequence. 

 

1. Open the GCS Loader Utility from the SG Hardware Tree by right-clicking on the Cluster icon  and then selecting 
‘Load’ from the context menu. 

 
2. Select the EZ80 tab and click the [Get Controller Info] button to see a list of all your controllers in the status textbox. 

Use the scrollbar on the status textbox to view each panel. You can verify what flash each panel CPU is running and see 
which model of CPU (600 vs 635) is in the panel. Note: Offline panels will not appear in this list. You can identify offline 
panels in the Loop Diagnostics screen. 

 
3. Click [Browse] button to open the Flash folder, then open the “600” folder. 

 
4. In the “600” folder, you must select the correct .S28 Flash File for your panel based on the Cluster Type (i.e. ‘635 only’ 

or ‘600 only’ or ‘mixed cluster’ with both 635 & 600 panels). See Part-2 if needed. 

• If you have a mixed cluster, you may need to browse to the Factory Test Folder to find your required file. 

• default location for current flash 600 & 635 Clusters is C:\GCS\System Galaxy\Flash\600 

• for alternate 600 flash C:\GCS\System Galaxy\FTS635\Factory Test\S28 files\600\600 CPU\Previous Version CPU S28 

• for alternate 635 flash C:\GCS\System Galaxy\FTS635\Factory Test\S28 files\635\635 CPU\Previous Version CPU S28 
 

 
5. Select the appropriate version flash file and click [Open] button to link the flash file to the Loader Utility. 

 
6. In the Controller droplist, select the controller unit number that you wish to flash. 

NOTE: It is not recommended to flash all controllers at the same time. 
 

7.  
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Upgrade Notice: if you are performing a stepped flash upgrade on older panels , you must always verify daughter 
boards are connected before you allow board updates. You must bring boards up to each stepped flash version. 

 

8. Click the [Begin Flash Load] button to update the CPU flash. The GCS Loader status textbox will show the flash packets 
being sequentially loaded. It will take several minutes to reach 100%. 

Do not skip. After 100% is reached, you must wait for the “Validate and Burn” option to automatically pop up. 

While you are waiting, the Loader Status Textbox will display several messages as follows: 

a. The status textbox will display “EZ80 Flash Load Finished” followed by “Flash Validated Successfully”. 

b. Continue waiting until the Confirmation popup window opens. Then you must select the option to 
[Validate and Burn Permanently Into Flash] – and click the OK button. Do not choose a different option. 

c. The controller will disconnect from the Event Service When the flash burn begins. 
(The event “Controller# Disconnected from Event Server” is logged in the SG Event screen). 

d. After several minutes, the flash burn will complete, and the controller will reconnect to the Event Service. 
(The event “Controller# Connected to Event Server” is logged in the SG Event screen). 

e. Verify that the Loader status textbox shows the correct “Flash version #” along with “Came up in Flash mode” 
and “Last Reset = Cold Start” messages. 

 
9. Verify that all the daughter boards are truly connected before you start flashing daughter boards: 

a. Open the SG Controller Properties screen and select the controller you have just flashed. 
b. Click the [Get Board Info] button to open the Board Information window, which lists the detected boards. 
c. Verify that the same boards are listed in the Interface Boards tab and the Board Information window. 

• Verify that each Board # and Board Type matches. Notice that the board flash is not yet updated (this is expected). 
• If a daughter board is not listed in the Board Information window, you must recover the board before it can be flashed. 

 

 

10. To start flashing the daughter boards, click the [Allow Board Updates] button in the GCS Loader\EZ80 Tab. 

a. Each daughter board will update its flash in random sequence. This will take several minutes. 
b. Each board will disconnect while flashing (a “stop communicating” event is logged in SG Event screen). 

c. Each board will reconnect when finished (a “Board Started Communicating” event is logged in SG Event screen). 

d. Verify each daughter board’s flash version is updated: Click [Get Board Info] button to refresh the screen. The 
Board Information window shows the currently detected flash version. Note: It may take up to 3 minutes to see a 
board’s flash version update. 

e. If you have a DSI-Board with Remote Door Modules (DRMs), the Remote DRMs will automatically begin flashing. 
» To verify flash update, click the [Get RS-485 Device Info] button in the SG Controller Properties screen. 
» Click the REFRESH button to keep checking the flash update status. 
» Remote DRMs update flash in a random sequence. This takes several minutes per board. 

11. If you are stepping up flash to interim versions, return to step-2 in this section to flash panels to the next interim 
version according to your Flash Update Chart. Remember to update all daughter boards for each interim version. 

 
12. If you have updated to an interim flash version, you can repeat these steps to flash up to the next version. After all 

boards in the panel are updated to the Required Version, you must Load Data – see Loading Data in this guide. 
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Upgrade Notice: see the Flash Upgrade Charts to determine which stepped interim flash version to load, as needed. 

 

Method-B - Updating Flash from the 635-CPU Webpage 
 

 Before beginning the flash process, reference the Flash Upgrade Charts in this guide for correct flash sequence. 
 Recommend using the “.bin” Flash file. 
 To open the webpage, the controller door must be open and the ‘Enable web server’ option must be on(checked). 
 Offline panels cannot be flashed with this method. 

 
1. Enter the CPU’s IP Address into the PC browser address bar. The embedded Panel Status webpage will display. 

2. From the Panel Status page, you can see the flash versions displayed for the CPU and all attached daughter boards. 
Notice which daughter boards are in the Boards list. Be sure they remain connected during CPU flashing. 

3. Click the ‘Update Firmware’ link to open the page to flash the CPU. 

4. Click [ Browse ] button and navigate to the appropriate flash folder. 
• If you have a mixed cluster, you may need to browse to the Factory Test Folder to find your required file. 
• default location for current flash 600 & 635 Clusters is C:\GCS\System Galaxy\Flash\600 

• for alternate 600 flash C:\GCS\System Galaxy\FTS635\Factory Test\S28 files\600\600 CPU\Previous Version CPU S28 

• for alternate 635 flash C:\GCS\System Galaxy\FTS635\Factory Test\S28 files\635\635 CPU\Previous Version CPU S28 

5. Select the appropriate .bin flash file based on which type of Cluster this controller is in (635 vs 600, or mixed). 
 

6. Choose the 635-CPU .bin file (recommended) to load flash to the CPU. 

7. Click the [Upload and Flash] button. Flashing will take a few minutes. 

8. After the CPU is finished flashing, the panel will reset and user will be returned to the All Panel Summary Page. 

9. Click the IP Address of the controller you were flashing to open the Panel Status Page. 

10. Verify the CPU software version has been updated to the correct flash version number. Note: Daughter boards on the 
panel should all be connected, but will not have updated their flash yet. 

11. To begin flashing daughter boards on the I2C Bus, click [Clear Auto-Update Timers] button. This takes several minutes. 

a. To verify daughter boards have finished updating, you can watch the board Status field in the Panel Status Page. The 
boards update in random sequence. As the update occurs, the Status field will change to “Flashing” for each board. 
When a board is finished, its Version field will update to the new flash version and its Status returns to “Normal”. 

b. If you have a DSI board with Remote Door Modules on its RS-485 channel, the remote DRMs will automatically start 
updating after the DSI has finished flashing. Remote DRMs update flash in random sequence. 

To verify remote DRMs are automatically updating, you can watch the Versions update in the Scan Lock window. 
» On the Panel Status Page, click the serial number of the DSI Board. This opens the DSI Test Page. 
» Set the Section field to the desired section (one or two). 
» Set the Function to “Galaxy Dual Reader Module” and click the [Apply] button. 
» Click the [Scan for Locks] button to open the Scan Lock window. You will see a list of the detected DRM locks 

and their Boot and Flash Versions (software version). It takes several minutes to update each DRM. 
» After the Boot Version is updated, each board/lock will momentarily disconnect and drop off the Scan list. 

When the DRMs reconnect, the Software Version field should display the new flash version. 

12. If you have updated to an interim flash version, you can repeat these steps to flash up to the next version. After all 
boards in the panel are updated to the Required Version, you must Load Data – see Loading Data in this guide. 
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Method C - Updating Flash from the Factory Test Station 
 

 You must have a 635-CPU running v10.4.9 or higher to use the Factory Test Station. 

 If you lose a daughter board during the flash process, you must recover the board to finish flashing. 
 

To perform this method you must use the FTS Guide: see the Factory Test Station Procedure (PDF) 
 
 
 
 

Loading Data using the GCS Loader Utility 
 
 The target Controller must be connected to the Event Server 
 Offline panels cannot be loaded. 
 The system programming should be completed before you Load Data Load. 

 
 

1. Sign into System Galaxy if you have not done so already. 

2. In the SG Hardware Tree, right-click on the Cluster icon  and select ‘Load’ from the context menu. 
Note: this automatically sets the Cluster field when it opens the GCS Loader Utility. 

3. Select the Controller name you wish to load. 
Note: (optional), you can load data to all panels on a cluster by choosing “All Controllers” in the Controller droplist. 

4. In the Load Data tab, you can see that most of the checkboxes are already checked. Since the panel has been flashed 
and cold started, you must load all the data including all card data. 

5. Select (check) the “All Card Data” option. (This will cause the ‘Card Changes Only’ option to become unchecked). 

6. All other options should be checked/loaded 

7. You can click the [Clear Status] button to clear the status field of any stale data from previous loads if needed. 

8. Click [Load Now] button to begin loading data. 

9. The GCS Loader Status field will display the packets of data as they are being loaded. 

10. After the loading has finished, you can close the GCS Loader window. 

11. From the View menu, you can open the Loop Diagnostics screen and execute the Get Controller Info or Get Total Card 
Count commands to check the controllers. 

• You should walk-test the system hardware to ensure it is working as desired. 

• If you make any changes to programming, you may need to reload your panels. 
 

http://www.galaxysys.com/sghelp/_docs/currdocs/QRS-QRG/635-FTS_DaughterBoard_FlashProcedure.pdf
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DIO/DSI FLASH NOTICE: You must disconnect all DIO and DSI boards from power before you flash the panel if the chart 
indicates. Flash all CPU & DRMs connected to the panel. Then, working with one board at-a-time, you will reconnect and 
update flash on each individual DIO or DSI board. Allow each board to finish flashing before connecting the next board. 

 

Flash Upgrade Charts 
 
 Sending a ‘Get Controller Info’ from the SG Loop Diagnostic screen will identify any 600-model panels on a cluster. 

 
1. Determine which Upgrade Chart you need: 

• use Table-3 if your cluster has “all 635-models” (no 600s). 
• use Table-4 if your cluster has any 600-model controllers. 

2. Locate your panel’s Starting Flash Version (in column 1 of chart). 
You identified your panel’s starting version in Part-2 of this guide using Table-2. 

3. Locate your Required Flash Version (in column 2 of the appropriate chart below). 
You identified your system’s required version in Part-2 of this guide using Table-1. 

4. If your Starting Version and Required Version are on different rows, then you must flash the panel by 
stepping-up the CPU flash to each interim version (row-by-row) until you reach your required version. 
Refer to the appropriate instructions in Part-3 (Method-A or -B) on how to update flash. 

• You must update all boards at each interim version before proceeding to next version. 
See the DIO/DSI Flash Notice for certain versions. 

• (I2C Bus) the ‘allow board update’ or clear auto command must be issued manually to update the 
boards on the I2C bus. 

• (RS485 Bus) all remote door modules (DRMs) must also be allowed to update. Remote DRMs will 
automatically start updating after the parent DSI has finished flashing. 

 

 
Table-3 : Flash Upgrade Chart for 635 Cluster (all 635 CPUs / no 600s) 

 

ROW STARTING CPU VERSION UPGRADE BEFORE ADVANCING TO NEXT ROW DIO/DSI FLASH NOTICE 
1 4.77 thru 5.00 5.04 < Disconnect DIO/DSI - Flash Notice applies 
2 5.04 10.4.15 – and update flash on all boards* < Disconnect DIO/DSI - Flash Notice applies 
3 10.4.15 10.5.6 – and update flash on all boards* N/A 
4 10.5.6 (or higher) flash straight up to the Required Flash Version that matches your SG 11 Software 

 
* Any 600-model DSI boards should be replaced with 635-DSI if the CPU will be updated to v10.5.6 or higher. 

 
 

Table-4 : Flash Upgrade Chart for 600 Cluster (all 600 CPUs / or Mixed Panels) 
 

ROW STARTING CPU VERSION UPGRADE BEFORE ADVANCING TO NEXT ROW DIO/DSI FLASH NOTICE 
1 v1.15 thru 1.74 2.30e < Disconnect DIO/DSI - Flash Notice applies 
2 2.30e thru 5.00 5.04 < Disconnect DIO/DSI - Flash Notice applies 
3 5.04 10.4.15 – update flash on all attached boards < Disconnect DIO/DSI - Flash Notice applies 
4 10.4.15 10.5.6 – update flash on all attached boards  

(v10.5.6 is the maximum possible flash for a 600 cluster or mixed cluster) 
 

* If a 600 or 635 controller has any 635 daughter boards, they will also be synched to the CPU version. 
635-DSI is not compatible with 600-CPU. 

 For SG 11 systems, 600 and mixed clusters cannot exceed v10.5.6 flash. 
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