System Galaxy Interface Manual
for the
BOSCH Alarm Panel

Revision 1.4
This document is a System Galaxy Product Interface manual. Information in this document is subject to change without notice. No part of this document may be reproduced, copied, adapted, or transmitted, in any form or by any means, electronic or mechanical, for any purpose, without the express written consent of Galaxy Control Systems. Copyright protection claims include all forms and matters of copyrighted material and information, including but not limited to, material generated from the software programs, which are displayed on the screen such as icons, look and feel, etc.

Table 1: Revision History

<table>
<thead>
<tr>
<th>Rev. #</th>
<th>Date</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>07/08/2005</td>
<td>Draft: SG 7.02 interface with the Bosch Alarm Panel</td>
</tr>
<tr>
<td>1.1</td>
<td>08/10/2005</td>
<td>Addition of screen shots</td>
</tr>
<tr>
<td>1.2</td>
<td>08/11/2005</td>
<td>Addition of Services</td>
</tr>
<tr>
<td>1.3</td>
<td>9/27/05</td>
<td>Added info about Ethernet Module</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Added info about Alarm Panel Services with encryption</td>
</tr>
<tr>
<td>1.4</td>
<td>10/4/05</td>
<td>Formatting and Layout</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Final revisions</td>
</tr>
</tbody>
</table>

List of Supporting Reference Documentation

<table>
<thead>
<tr>
<th>Document</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Galaxy Hardware Manual</td>
<td>The main Hardware Manual describes general information and instructions that pertain to installation, specifications, and programming of the hardware. This manual is on the System Galaxy Software CD and the Galaxy website.</td>
</tr>
<tr>
<td>System Recommendations for SG-7</td>
<td>This is a quick reference document for the general system recommendations for SG-7 not including Event Server. These requirements are available on the first chapter of the main Software Manual which is on the System Galaxy Software CD and the Galaxy website.</td>
</tr>
</tbody>
</table>

Galaxy Control Systems

PO Box 158
3 North Main Street
Walkersville, MD 21793
Phone: (301) 845-6600
Fax: (301) 898-3331
email: info-usa@galaxysys.com
website: www.galaxysys.com

Page 2 of 37
# Table of Contents

1. Introduction .................................................................................. 5  
   1.1 Overview of System Galaxy Alarm Panel Interface ....................... 5  
   1.2 About the Bosch Alarm Panel ....................................................... 6  
   1.3 How System Galaxy communicates with the Alarm Panel ............... 6  
   1.4 About the GCS Alarm Panel Service ............................................. 7  

2. Configuring System Galaxy ......................................................... 8  
   2.1 Physically Connecting to the Alarm Panel ....................................... 9  

3. Register System Galaxy for Alarm Panel .................................... 10  

4. Setting Workstation Options ...................................................... 11  
   4.1 Setting the path to the Alarm Icons .............................................. 11  
   4.2 Setting the Alarm Options .......................................................... 12  

5. Add an Alarm Panel in System Galaxy ........................................ 13  

6. Add an Alarm Panel Area in System Galaxy .............................. 15  

7. Add an Alarm Panel Point in System Galaxy .............................. 16  

8. Managing GCS Alarm Panel Service ........................................... 21  
   8.1 Starting the Alarm Panel Service .................................................. 22  
   8.2 Setting the Alarm Panel Service to start automatically .................... 23  
   8.3 About the GCS Alarm Panel Server (service) .................................. 24  
      8.3.1 GCS Alarm Panel Service system requirements ....................... 25  
      8.3.2 How to open or close the Alarm Panel Service window .............. 25  
      8.3.3 How to connect to the Alarm Panel ....................................... 26  
      8.3.4 Managing Properties of the Alarm Panel Connection ................ 27  
      8.3.5 How to see and manage the IP connections between services ....... 28  
      8.3.6 Log File for GCS Alarm Panel Service .................................... 29
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>9</td>
<td>Getting Events from the Alarm Panel</td>
</tr>
<tr>
<td>10</td>
<td>Command Menus for the Alarm Panel</td>
</tr>
<tr>
<td>11</td>
<td>Device Status for Alarm Panel</td>
</tr>
<tr>
<td>12</td>
<td>Adding Icons for the Graphics screen</td>
</tr>
<tr>
<td>13</td>
<td>Placing Alarm Points on the Graphics screen</td>
</tr>
<tr>
<td>14</td>
<td>Crystal Reports for Alarm Panel Events</td>
</tr>
<tr>
<td>15</td>
<td>Managing User Codes for Alarm Panels</td>
</tr>
<tr>
<td>15.1</td>
<td>Managing Alarm Panel User Codes</td>
</tr>
<tr>
<td>15.2</td>
<td>Assigning Alarm Panel User Codes to Cardholders</td>
</tr>
</tbody>
</table>
1 Introduction

This manual describes registration, setup, and operation of the System Galaxy Alarm Panel Interface to the Bosch Alarm Panel.

This manual also includes specific information about alarm panel settings that are required in order to connect with System Galaxy 7.2 or higher (covered in section 2.1). This manual does not replace or supersede the manufacturer’s manual. Installer must refer to manufacturer’s documents for complete information pertaining to the Alarm Panel or Alarm System (i.e. installation, wiring, programming, use).

1.1 System Galaxy supports the following alarm panel features:

- SG receives real-time status messages from the alarm panel when the panel is on-line with SG
- SG is able to monitor alarm conditions and points can be linked to SG Alarm features
- SG can send typical system commands to the alarm panel (i.e. Arm/Disarm, Bypass/Un-Bypass, etc. depending on operator privileges and panel programming)
- SG supports the Always Armed -24 Hour Point and Bypass Allowed features. Note that 24-hr Points cannot be bypassed even if the Bypass Allowed option is checked. And points cannot be bypassed if Bypass option is not checked or if the operator privileges do not allow the option.
- SG can link alarm points to Galaxy Alarm Events, DVR Cameras and CCTV Systems.
- SG can send (add) and retrieve (get next available/unused) user codes and assign user codes to multiple cardholders. Ability to ac32cess this type of programming depends on operator privileges.
- SG can send text messages to the keypad. The static message displays until replaced with next message
- SG can retrieve “point text” from the alarm panel.

1.2 Requirements: System Galaxy interface with alarm panel

- System Galaxy 7.02 (or higher) interfaces with the Bosch 9000/7000 series alarm panels.
- The alarm panel should be installed and configured before configuring System Galaxy. The installer should install and configure the Bosch Alarm Panel according to the manufacturer’s documentation. Section 2.1 of this manual includes known settings for connecting to the alarm panel.
- System Galaxy must be registered for Alarm Panel interface before it can be configured for the alarm panel. Once registration is complete, the Alarm Panel, Areas, Points and User Codes can be added to System Galaxy.
- The GCS Alarm Panel Service must be running in order to connect and receive/send events. The AP Service runs as a true background service and independent of user logins.
- The GCS DBWriter Service must be running for the Alarm Panel service to connect to the panel
- The GCS ClientGW Service must be running for human-readable events to display at the monitor; also this service must be running for operator to send commands to the panel.
1.3 The Bosch Alarm Panel from a Galaxy perspective

- Bosch has alarm inputs called “points” at the panel wiring terminals. Refer to Bosch product manual. (Points can be defined in System Galaxy to reflect the true alarm panel programming.)

- Several points can be configured to represent an “Area”. Refer to Bosch product manual for details. (Areas can be defined in System Galaxy to reflect the true alarm panel programming.)

- The alarm panel installer will program the points and areas at the alarm panel when the Alarm System is installed. System Galaxy software does not support the panel-level programming. Once the panel is programmed System Galaxy should be configured in to match.

- The panel supports over 200 user pass codes. Refer to Bosch product manual for details. System Galaxy can be used to manage pass codes (i.e. add codes to the panel and link codes to cardholders).

- The panel sends only real-time status messages (every few seconds) to System Galaxy provided the PC connection to the panel is established and provided the correct GCS Services are running. The rate that messages are sent is a programmable value at the panel. Refer to Bosch product manual for details. The alarm panel does not buffer and resend off-line events to System Galaxy.

1.4 How System Galaxy communicates with the Alarm Panel

System Galaxy uses GCS Services to communicate with the Alarm Panel.

- See section 1.5 for an overview of the GCS Services;
- See section 8 for setting up and starting the GCS Alarm Panel Service;
- find in-depth information on Managing GCS Services in the Main Software Manual for SG-7.

- SG has the ability to monitor the condition of the alarm points (alarm conditions):
  1. The Bosch Panel sends real-time status updates to SG every 1-2 seconds. This is an adjustable value at the panel. Bosch product manuals cover the programming of the panel.
  2. The real-time updates include the following:
     - the status of all alarm points (secure/on or unsecure/off)
     - the status of all areas (arm/disarm)
     - panel-level alarms such as low battery and AC failure
  3. Alarm History Report available in SG for “online” status messages; online status messages are defined as the alarm panel events that occur when the panel is connected and communicating with System Galaxy.
  4. The Bosch panel does not send “off-line” status messages to SG upon reconnect. Offline messages are defined as alarm panel events that occurred while disconnected from System Galaxy.

- SG has the ability to send commands from System Galaxy to the alarm panel:
  1. arm and disarm entire panel
  2. arm and disarm individual areas
  3. bypass or unbypass individual alarm points (enable/disable the point)

- Ability to configure keypad “user codes” and download to the panel. These codes are user codes to the alarm system.
1.5 Overview of System Galaxy’s GCS Alarm Panel Service

The GCS Alarm Panel Service (AP Service) runs as a true background service and supports encryption. See Section 8 – Managing the Alarm Panel Service.

The AP Service should be set up to start automatically and must be running to support logging of alarm panel status/events. When the service is running, a gray Panel Icon will appear on the system tray of the PC. See Section 8 – Managing the Alarm Panel Service.

The AP Service receives the messages (real-time status) from the alarm panel and sends them to the DBWriter and the Client Gateway service. The DBWriter will record the alarm panel status in the System Galaxy database. And the Client Gateway service will build the human-readable messages to be displayed in the System Galaxy software on the Alarm Panel status screen.

When first started, the system generates an initially reported condition (secure/safe or unsecure/alarm) based on the current condition at panel for each point (zone).

Alarm Panel status messages are time-stamped by the Communication Server. The DBWriter Service stamps the time for the record logged in the database and Client Gateway Service stamps the time for the Event screen.

FIG 1: Interface Diagram depicting necessary GCS Services
2 Configuring System Galaxy

The following steps are required to properly setup System Galaxy to interface with the alarm panel.

<table>
<thead>
<tr>
<th>Step</th>
<th>Action</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>All installation, wiring and programming of the Alarm Panel should be completed before configuring System Galaxy. <strong>The Alarm Panel should be installed and fully configured before configuring System Galaxy.</strong></td>
<td>Manufacturer’s documentation</td>
</tr>
<tr>
<td>2</td>
<td>Connect the alarm panel to the System Galaxy Communication PC (the computer running GCS services) including known requirements.</td>
<td>Sect 2.1 – Connecting to the Alarm Panel and the manufacturer’s documents</td>
</tr>
<tr>
<td>3</td>
<td>Register the <strong>Alarm Panel Support</strong> in System Galaxy</td>
<td>Section 3</td>
</tr>
<tr>
<td>4</td>
<td>Setup Workstation Options as needed:</td>
<td>Section 4</td>
</tr>
<tr>
<td></td>
<td>A – specify the Graphics path for Alarm Icons (section 4.1)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>B – set the Alarm Options for the Workstation (section 4.2)</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Add (setup) the Alarm Panel in System Galaxy to match the setup of the Bosch Alarm Panel.</td>
<td>Section 5</td>
</tr>
<tr>
<td>6</td>
<td>Add (setup) the Alarm Areas in System Galaxy to match the setup of the Bosch Alarm Panel.</td>
<td>Section 6</td>
</tr>
<tr>
<td>7</td>
<td>Add (setup) the Alarm Points in System Galaxy to match the setup of the Bosch Alarm Panel.</td>
<td>Section 7</td>
</tr>
<tr>
<td>8</td>
<td>Setup and Start the Alarm Panel Service – this service is installed to run automatically by default and should be running. Note that additional information for managing the service is provided in Section 8, however the service should install to the proper default settings. The additional information is included to explain settings and operation default settings are to be altered.</td>
<td>Section 8</td>
</tr>
<tr>
<td></td>
<td>8.1 – starting the service</td>
<td></td>
</tr>
<tr>
<td></td>
<td>8.2 – setting service to start automatically</td>
<td></td>
</tr>
</tbody>
</table>

At this point System Galaxy should begin receiving events from the Alarm Panel. The remaining sections cover operating the System Galaxy Alarm Panel features.

- Getting Status Events from the Alarm Panel
- Command Menus for the Alarm Panel
- Device Status screen for the Alarm Panel
- Adding Icons for the Graphics Screen
- Placing Alarm Points on the Graphics screen
- Crystal Reports
- Managing Alarm Panel User Codes from System Galaxy
2.1 Physically Connecting to the Alarm Panel

### STEP 1: Install and program the Alarm Panel according to the Manufacturer’s Instruction

The Alarm Panel should be installed and fully configured before connecting to System Galaxy.

### STEP 2: Connect the Alarm Panel to the System Galaxy Communication Server/PC

Bosch 9000/7000 Series alarm panels can connect to the SG Communication PC by three possible choices described below. Note that these include parameters required for System Galaxy. The ‘SG Communication Server (PC) is defined as the computer running the GCS Services (including the Alarm Panel service).

#### a) (CHOICE A) Ethernet Device (most common) DX4020 Module: installer must set up the module including the following known requirements:
- **Use wiring info in Bosch install documentation**
- **DIP switch settings** 1 thru 6 and 8 = down/off and 7 = up/on
  - a. Flow control = none
  - b. UDP datagram = disable (to use TCPIP)
  - c. telnet port = 9999
  - d. Set connect mode to “C0” (C, zero) instead of “CC”;
- **Supports encryption** - special configuration info in the Bosch manuals. This is set at the module via telnet and must be set on the System Galaxy end in the Alarm Panel Service screen. Whatever is set at DX2040 module must match the setting in the Alarm Panel Service. See Section 8 for how to configure encryption at the Alarm Panel Service.
  - key length = 128 (default); must be zero if not used.
  - must specify a key value: the key value is a 16 digit hex code; must be blank if not used.
    - Example: ‘01020304050607080910111213141516’ is an example of a 16 digit hex code, which is actually 32 characters long; a hex digit is made of 2 characters. Valid hex characters are: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, F. Therefore a hex value of ‘01’ = 1 and ‘0A’ = 10 when converted to decimal value.

#### b) (CHOICE B) Direct connect using RS 232 Connection Module such as the Model DX 4010i:

- **Wiring info** is in the Bosch Install documentation for com to panel
- **DIP Switch settings** are 1,2,3,4 = UP and 5,6,7,8 = DOWN
- **9600 Baud, no parity, 8 bit, 1 stop bit**
- **Uses DB9 RS232 cable** to connect to PC com port

<table>
<thead>
<tr>
<th>Pin Out for RS-232 Cable</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB9 female</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>5</td>
</tr>
</tbody>
</table>

#### c) (CHOICE C) Direct connect (as above) with Lantronix: IP on the SG COMM SIDE TO LANTRONIX

- Configure Lantronix device the same as with Network Bridge for a Remote Primary 508 panel. See the Lantronix manual for configuration information.
3 Register System Galaxy for Alarm Panel

The alarm panel is registered in the System/Product Registration screen. This screen can be opened through the Registration Wizard (first screen) or the System Registration screen.

STEP 3: Register System Galaxy for the Alarm Panel Support:

- Open the System Galaxy software by double-clicking on the SG icon located on the PC desktop of the Communication Server.
- Open the System Registration screen from the main menu by selecting Configure>Options>Registration>System (or use Wizard)
- In the main System Registration screen, the Alarm Panel Support option must be checked.
- Complete the normal registration process through the Galaxy Control System’s Online Registration or through Galaxy Control Technical Support. (Product registration must be performed by the certified Galaxy Dealer and is dependent on purchased options).

FIG 2: System Registration screen (cropped)
4 Setting Workstation Options

This section describes setting up Workstation Options that are related to alarm features. The settings for alarm options and the path to the alarm icons are set in the Workstation Options screen.

4.1 Setting the path to the Alarm Icons

The multi-media path to the alarm icons must be set to the correct directory for the system to find the correct graphics used in mapping and displaying status of alarms (see section 4.1).

**STEP 4: Check the Workstation Options related to Alarm Panel interface:**

**Part 1:** Open Workstation Options screen from SG menu: Configure>Options>Workstation Options.

**Part 2:** Select the Multi-Media tab and verify that the path for the graphic icons is set as needed:
- The default path is set to “C:\Program Files\System Galaxy\Icons”.
  
  **Note:** If a different directory (shared directory) is used, then browse to that location. You may need to copy the alarm panel icon-graphics to that location if they have not already been moved. Also, if the path to the System Galaxy folder has been installed in a different location than the default installation path, user will need to browse to that path.
- Click APPLY and OK to save changes

**FIG 3: Workstation Options screen – Multi-Media tab (cropped)**
4.2 Setting the Alarm Options

Workstation alarm options determine how the Workstation behaves when Alarm Events occur for acknowledgeable alarms. An acknowledgeable alarm is defined as ‘a detected event that meets the criteria (device programming) to trigger an SG Alarm Event’. Acknowledgeable alarms may or may not generate an SG Alarm Event depending on the condition and also on local workstation option settings.

Part 3: Pick the Alarm Options tab and set/verify that the following options are set as needed: the table below is an abbreviated list of the pertinent workstation alarm options. The remaining alarm options are discussed in full in the main SG7 Software Manual - Chapter 15.

- Click APPLY to save changes

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pop up on Alarm</td>
<td>(default to checked/on) When checked, System Galaxy pops the SG Alarm Event screen to the front when an acknowledgeable event is detected.</td>
</tr>
<tr>
<td>Automatically call up DVR Video</td>
<td>(default to checked/on) – allows DVR Viewer to start when alarm event occurs. When checked, System Galaxy starts the GCS DVR Viewer window if a dvr/camera is linked to the alarm point. The DVR Viewer shows live video for the camera that is linked to the activated alarm panel point.</td>
</tr>
<tr>
<td>Prevent Appl. Shutdown w/ Pending Alarms</td>
<td>(default to checked/on) When checked, operator is unable to close the System Galaxy when a “pending” (unacknowledged) alarm is active in SG Alarm Event screen.</td>
</tr>
<tr>
<td>Allow Acknowledge all alarms</td>
<td>(default to checked/on) – acknowledge all command clears the alarm events. When checked, the operator can select the ‘acknowledge all’ option from the command menu (shortcut menu) in the SG Alarm Event screen.</td>
</tr>
<tr>
<td>Acknowledge alarm priority range</td>
<td>(Defaults to 0 -9999) - allows client to set the range for acknowledgeable alarm events on a per workstation basis. (acknowledgeable = alarm point set to ‘ack’) Acknowledgeable alarms outside of the specified range will not trigger an SG Alarm Event at the local workstation. Acknowledgeable alarms inside the range will display on the SG Alarm Event screen for the local workstation.</td>
</tr>
<tr>
<td>Force response above</td>
<td>(Defaults to 0) - allows client to define the threshold for alarm response based on priority. (acknowledgeable = alarm point set to ‘ack’) Acknowledgeable alarms with priorities below this value will not force a response from the operator. Acknowledgeable alarms above this value will require a response from the operator before alarm event will be cleared from the screen.</td>
</tr>
</tbody>
</table>

NOTE: the Alarm Panel Point must be set to require acknowledgement (checked) in the Point Property screen. Also the alarm priority set in the Alarm Point Property screen must be within the acknowledgeable alarm priority range defined in the Workstation/Alarm Options screen.

FIG 4: Workstation Options screen – Alarm Options tab (cropped)
5 Add an Alarm Panel in System Galaxy

The alarm panel must be added in the System Galaxy software before the GCS Alarm Panel Service will connect to the panel. The programming must match the Alarm Panel configuration.

After Panel, Areas and Points are added, System Galaxy can begin receiving status events from the alarm panel. The alarm panel events are displayed in the Alarm Panel Event screen.

STEP 5: Add an Alarm Panel as follows: (SG main menu: Configure>Hardware>Alarms)

Part 1: open the Alarm Panel Property screen (Configure>Hardware>Alarms>Alarm Panels)
Part 2: click the Add button and set the following fields as needed:

- **Name field**: type a descriptive name
- **ID number**: (the system assigns the system ID)
- **Panel Type**: pick ‘BOSCH D9000/D7000 Series from the droplist
- **Connection Method**: choose appropriate connection type (also see Step 1 of Section 2.1)
  - a) **On Board Ethernet**: if connecting to the Bosch DX4020 Ethernet module
  - b) **Serial Comm. Port**: if connecting to the Bosch DX4010i module
  - c) **Lantronix with TCP/IP**: if connecting to the panel via Lantronix device

- **IP Address**: enter the IP Address depending on the Connection Method chosen:
  - a) IP Address of the DX4020 Ethernet module if On-board Ethernet option is chosen
  - b) (not used) if Serial Com Port option for 4010i is chosen
  - c) IP Address of the Lantronix device if using Lantronix with TCP/IP option is chosen

- **Port Number**: enter the port number if an IP Address is used:
  - a) 3001 (Lantronix)
  - b) blank if direct connect (serial com port connection to 4010i)
  - c) 7700 (Ethernet 4020 Module)

- **Com Port (if using Serial Comm. Port)**: pick the com port being used at the PC
- **Baud Rate (if using Serial Comm. Port)**: set to 9600
- **Passcode**: blank/not used
- **Communication Server**: Enter Name of PC that will run the GCS Alarm Panel Service.

Part 3: click the Apply button to save the settings.

**FIG 5a: Alarm Panel Property screen (cropped)**
Additional Utilities explained on this page …

Also in the Alarm Panel Property screen are remote configuration options for the alarm panel. These are utility features that allow the operator to send commands or data to the selected Alarm Panel.

- **Virtual Keypad** = allows operator to mimic typing at the Bosch keypad. Allows up to 8 keypads. Allows operator to interface with the Bosch Alarm panel from System Galaxy.
  
  **To use the virtual keypad, do the following:**
  1. set the keypad number you wish to mimic
  2. type in the desired code
  3. click the [#] button
  4. click the [send] button to send the code to the alarm panel

- **Set Poll Rate** – allows operator to set the poll rate between the alarm panel and SG (in $10^{nth}$ of seconds)
  - 0 = OFF; don’t send any status
  - 5 = send status every 0.5 sec
  - 10 = send status every 1.0 sec
  - 15 = send status every 1.5 sec

- **Set User Code** – the system allows up to 249 user codes (per alarm panel specification). **Using this feature can overwrite an existing code at the alarm panel if the operator chooses a number that is already in use. If a user code is sent from this utility it is not stored in the SG database.**

- **Set Key Pad Text** allows operator to send 16-character text message to the Bosch keypad display. **NOTE:** this message will show on all keypads
6 Add an Alarm Panel Area in System Galaxy

The Alarm Panel Area should be added in the System Galaxy software. The programming must match the Alarm Panel Area configuration. An alarm panel area consists of 1 or more points.

After Panel, Areas and Points are added, System Galaxy can begin receiving status events from the alarm panel. (Note the alarm panel connection The alarm panel events are displayed in the Alarm Panel Event screen.

**STEP 6: Add an Alarm Panel Area as follows:** (SG main menu: Configure>Hardware>Alarms)

**Part 1:** open the Alarm Panel Areas Property screen (Configure>Hardware>Alarms>Alarm Panel Areas)

**Part 2:** pick the desired alarm panel name from the Select Alarm Panel droplist

**Part 3:** click the Add New button and set the following fields as needed:

- **Name field:** type a descriptive name (preferably that matches the panel)
- **Area Number:** enter the area number that matches the area in the alarm panel (1-8)
- **Show in Tree:** the show in tree checkbox allows Alarm Panel Area Icon to display in the System Galaxy Hardware Tree.

**Part 4:** click the Apply button to save changes

**NOTE:** The SG Hardware Tree may need to be refreshed to pick up the Area Icon. To refresh the hardware tree, simply close the tree’s window pane by clicking the [x] button at the top and reopen it from the SG View menu (select View>Hardware Tree).

**NOTE:** The Alarm Panel Area Icon will display under the specific Alarm Panel Icon to which it is assigned. Expand the Alarm Panels Icon, and then expend the Alarm Panel Icon to see the Alarm Panel Area Icon.

**FIG 6: Alarm Panel Area Property screen (cropped)**
7 Add an Alarm Panel Point in System Galaxy

The alarm panel point must be added in the System Galaxy software. The programming must match the Alarm Point configuration at the Alarm Panel.

After Panel, Areas and Points are added, System Galaxy can begin receiving status events from the alarm panel. The alarm panel events are displayed in the Alarm Panel Event screen.

**STEP 7: Add an Alarm Panel Point as follows:** (SG main menu: Configure>Hardware>Alarms)

**Part 1:** open the Alarm Panel Point Property screen (Configure>Hardware>Alarms>Alarm Panel Points)

**Part 2:** pick the desired Alarm Panel from the Select Alarm Panel droplist

**Part 3:** click the Add button and set the following fields as needed:

- **Point #:** (1-8) set the point number to match the Alarm Panel input terminal
- **Name field:** either type a descriptive name or use the [Get Point Text From Panel] button to get the actual point name from the alarm panel
- **Select Area:** pick an area name (must match area number set at Panel)
- **Acknowledge checkbox:** sets the alarm point to require acknowledgement
  - a) When checked, an armed-not normal(trouble) event logs to the event of armed-not normal(trouble) to the SG Alarm Event screen.
  - b) When unchecked, an armed-not normal(trouble) alarm event logs to the Alarm Panel screen (i.e. will not pop an alarm in the SG Alarm Event screen).
- **Priority:** sets the alarm priority for this alarm point (0-9999 valid)
  
  NOTE: The priority number in this field must be within the priority range in the Workstation Options/Alarm Options screen for an event to log in the Alarm Event screen at the local workstation (see Priority Range option in sect 4.2 of this manual).

  The SG Alarm Event screen will pop to the front window if the ‘pop on alarm’ option is check in Workstation Options (see Pop on alarm option in section 4.2 of this manual).
- **Show in Tree checkbox:** when checked, allows Alarm Panel Point Icon to show in the System Galaxy Hardware Tree.
- **Always Armed (24 hour point):** set this to “checked” only if the alarm point is a 24 hr armed at the Bosch Alarm Panel. NOTE: bypass is disabled in always armed state.
- **Bypass Allowed:** when checked, the operator can bypass/unbypass a point from command options on SG shortcut menus. When unchecked, the bypass options are not available on the command menus. (Commands are found by right-clicking the point’s icon, graphic or event messages in the System Galaxy screens.)
- **Operator Response Instructions:** type operator instructions to be displayed in the SG Alarm Event screen if an armed-not normal (trouble) from this Alarm Point will need an operator response (used when triggering SG Alarm Events in the software for incoming alarms).

Continue on the next page…
The fields on tabbed panels are described in the following sections
Graphic Symbols tab (if using the Graphics screen)

Allows operator to configure which icons represent each Alarm Panel status condition. User can choose the condition from the drop list and select an available graphic from the default directory or browse to a directory where graphics are stored.

- **Select status condition**: pick the condition to match with a graphic icon
- **Choose a graphic condition**: pick an icon to match to the selected condition
- **Use the [...] button** to browse to a different directory if desired
- **Use the [Copy Symbols from another Point]** to copy the icon configuration from a previously programmed alarm point. This is a quick way to reproduce the icon mapping for multiple points that use the same symbols.

- **Note that changes are saved when the [Apply] button is selected**

Note: it is a good idea to establish a standard color pattern. Consistency avoids confusion.

For example a pattern of color use could be as follows:

- red icons (doors, dots, etc.) used for ‘armed – not normal’ conditions
- green icons for ‘armed – normal’ conditions
- yellow icons for ‘unarmed – not normal’ conditions
- blue icons for ‘unarmed – normal’ conditions
- gray icons for ‘bypassed’ conditions
DVR Camera Settings tab

Allows operator to link status events from this alarm Point to a DVR unit and camera. When this option is configured, the system associate a camera with the designated alarm point. When programmed, the operator will be able to initiate DVR Viewing within system galaxy for the alarm point.

- Video can be manually started by the operator by right-clicking the Alarm Point Icon in the hardware tree and then picking the ‘View Live Video’ option from the shortcut command menu. The view live video option is available from graphics screen, device status screen, alarm panel event messages. See the GCS DVR Interface Manual for your type of DVR to find more information on DVR Interface features.

- The software will also automatically pop open the DVR Viewer if the point is set to require acknowledgement of the armed-not normal/trouble. See Section 4.2; Part-3 for Alarm Options related to popping alarms and automatically starting the Viewer.

- **Select a DVR Name:** the DVR must already be registered and configured – Refer to the GCS DVR Interface Manual for your DVR for setup and operation instructions.

- **Choose a Camera:** the camera(s) must already be configured

- **Note that changes are saved when the [Apply] button is selected**

FIG 7c: DVR Settings tab (cropped)
**CCTV Events tab**
Allows operator to set CCTV parameters to be sent to CCTV system.
- **Alarm number** = must be greater than zero; allows user to set the number to send to the CCTV service/system. Zero means no alarm message is sent to CCTV system.
- **Camera, Monitor, Position, fields** allow SG to send commands to CCTV system.
- **Manual command** = if programmed, the user can send commands from the short menu in the hardware tree.
- **URL** = if programmed, can invoke commands at the web site
- **Note that changes are saved when the [Apply] button is selected**

**FIG 7d: CCTV Events tab (cropped)**

**Audio Settings tab**
Allows user to set audio indicators for alarm and trouble conditions.
- **Click the Alarm Audio / […] button** to browse to the desired audio file to be sounded for an alarm condition.
- **Click the Trouble Audio / […] button** to browse to the desired audio file to be sounded for a trouble condition.
- **Note that changes are saved when the [Apply] button is selected**

**FIG 7e: Audio Settings tab (cropped)**

**Part 4:** click the **Apply** button to save changes
- **Once the Alarm Panel is configured and the necessary GCS Services are running, System Galaxy can begin receiving alarm panel status messages.**
Managing GCS Alarm Panel Service

GCS Alarm Panel Service runs as a true background service and should be set up to start automatically when the PC starts. The AP Service icon displays a gray alarm panel icon in the system tray.

**IMPORTANT:** the AP Service has a dependency to the DBWriter service and drops its connection to the alarm panel if the DBWriter is offline. The DBWriter Service must be running to receive events.

The following GCS Services must be running for alarm panel events to display at System Galaxy and be recorded in the database (i.e. available in history reports).

- The GCS DBWriter Service must be running for messages to log to the database and for the Alarm Panel Service to connect to the database.
- The GCS Alarm Panel Service must be running and connected and to the panel.
- The GCS ClientGW Service must be running for the status events to display in SG

Each of these services maintains one ODBC connection to the database. For more information on GCS Services see the System Galaxy Software Manual for SG v7.

FIG 8: Diagram of Services
8.1 Starting the Alarm Panel Service

After the Alarm Panel is configured and the necessary GCS Services are running, System Galaxy can begin receiving alarm panel status messages.

The Alarm Panel Service should be configured to start up automatically when the PC boots up (section 8.2) and to automatically connect to the alarm panel. Operator can manually connect to the alarm panel from the Alarm Panel Service window (see section 8.3.3 part 4).

If the alarm panel service or other services do not start or connect automatically, use the following steps to setup the services as desired.

**STEP 8a: Start the Services (do each part as needed)**

**Part 1:** Verify that the *Alarm Panel Icon* is displayed on the system tray of the SG communication server.

*Hovering the mouse over the Alarm Panel Service icon will cause the Alarm Panel name to display.*

a) If the Icon is visible, double-click it to open the *Alarm Panel Service screen* and skip to **Part 4** in Section 8.3.3

b) If the Icon is not displayed on the system tray of the Communication Server, then proceed to **Part 2** below.

c) **NOTE** that the DBWriter Service must be running in order for the Alarm Panel Service to be able to connect to the alarm panel.

d) **NOTE** that the ClientGW Service must also be running to see alarm panel messages at the computer.

**Part 2: To Start the Alarm Panel Service**, open the *Services window*: note also start any other GCS services as necessary (ref Part 1-c and d). See FIG 9 on the next page for an example.

a) **EITHER** > Right-click the *My Computer icon* on the desktop and select the *Manage* option then find and open the *Services window* under the *Services and Applications* branch in the Computer Management window.

b) **OR** > click the PC *Start button*, select *Settings>*Control Panel on the menu and open the *Administrator Tools* folder, then open the *Services* window. Scroll down to find the *GCS Alarm Panel Service* in the list.

  - Right-mouse-click the name of the *GCS Alarm Panel service* to display a shortcut menu that lists the options to *start, stop* or *restart* the service.

  - Pick the option to start the service – when service starts a gray alarm panel icon will display on the PC’s system tray in the bottom right corner of the screen.

  - If the service icon does not appear after starting/restarting, then check that the service is set to interact with desktop. See step 8b part-3.

**IMPORTANT:** Stopping or restarting services temporarily interrupts communications between System Galaxy and the Alarm Panel. The panels will operate offline from System Galaxy, but will not transmit any offline events upon reconnect.
8.2 Setting the Alarm Panel Service to start automatically

The Alarm Panel service should install to ‘automatically start’ when PC boots up. If this option has been disabled, do the following:

**STEP 8b: Set the Services to start automatically (do each part as needed)**

**Part 3: To set the Alarm Panel Service to start automatically do the following**

- To open the Services window, user can do one of the following:
  - **EITHER** > Right-click the My Computer icon on the desktop and select the Manage option then find and open the Services window under the Services and Applications branch in the Computer Management window.
  - **OR** > click the PC Start button, select Settings>Control Panel on the menu and open the Administrator Tools folder, then open the Services window. Scroll down to find the GCS Alarm Panel Service in the list.

- Scroll down to find the GCS Alarm Panel Service in the list.
- Right-click the name of the GCS Alarm Panel Service to show the shortcut menu
- Pick the ‘Properties’ option on the short menu
- Pick the General tab and find the [Start Type] field
- Pick the ‘Automatic’ option in the drop list
- Note that the Interact with desktop option is also found in this window on the Logon tab. This must be checked in order for the service to display on the system tray.
- Click on [OK] button to save settings – the service will start automatically the next time the PC is rebooted/restarted
8.3 About the GCS Alarm Panel Server (service)

The GCS Alarm Panel service automatically connects to an alarm panel if the alarm panel is properly installed, registered, and configured in System Galaxy. Registration and setup are described in the following sections. This section includes pertinent notes about how the GCS Alarm Panel service works.

The Alarm Panel Service listens on port 4004

Client Server Relationships:
- Server relationship to GCS ClientGW Service (client gateway)
- Client relationship to the GCS DBWriter Service

Functionality:
- Makes/Manages connections to Alarm Panels when the GCSDBWriter is up/running.
- Provides communication between GCSClientGW Server, GCSDBWriter and alarm panels.
- Maintains ODBC connection to SysGal DB.

Troubleshooting TIPS:

a) Stopping the GCS Alarm Panel service will interrupt alarm panel statuses to the System Galaxy Application(s) and to the System Galaxy Database. The alarm panel does not retransmit offline status messages to SG or SG database after reconnection.

b) If only the Client Gateway service is stopped, the alarm statuses may still be available in the database through system reports after the GCS ClientGW service is restarted.

c) If only the SG application is stopped, the alarm statuses may still be available in the database through system reports after the GCS ClientGW service is restarted.

d) If the DBwriter service is stopped, the Alarm Panels service will drop the connection to the panel and begin the reconnect retry cycle until connection is re-established with the DBWriter.

e) The Alarm Panel service will not connect to panels unless it is connection to the DBWriter first.

f) The Alarm Panel service will drop connections to panels if it looses connection to the DBWriter.

IMPORTANT: If the GCS DBWriter Service is stopped, the Alarm Panel service will automatically disconnect from the Alarm Panel. The Alarm Panel service is dependent on the DBWriter service to be running in order to connect to alarm panels.
8.3.1 GCS Alarm Panel Service system requirements

The following information should be considered in addition to the General System Requirements to run System Galaxy with services. See the System Recommendations for SG-7 document for general system requirements.

- 1 ODBC connection to the System Galaxy database (database server)
- 1 outgoing IP connection to DBWriter (database server)
- 1 incoming IP connection to Client Gateway (communication server)
- 1 connection (IP or 232) to each panel

8.3.2 How to open or close the Alarm Panel Service window

To open the AP Service window, operator must double-click the Alarm Panel Service Icon on the PC system tray. The system tray shows icons of services in the lower right-hand corner of the computer screen. Slowly hovering your mouse pointer over the icons will cause the service name to display.

A GCS Service window is opened by double-clicking its ICON on the Window® system tray.

![GCS icons](image)
The blow-up shows the icons for GCS Client Gateway, GCS DBWriter, and GCS Alarm Panel.

FIG 10: Close Service Confirmation Dialog box

Click the [X] button on the AP Server window and choose one of the following options.

- Select the Hide GUI, Keep Service Running to close the window and keep the service running minimized on the system tray.
- Select Exit, Terminate Service close the window and stop the service.
- Select Cancel to keep the window open.
8.3.3 How to connect to the Alarm Panel

The GCS Alarm Panel Service reads the alarm panel configuration from the SG database and begins making attempts to auto-connect to the panel at least 60 seconds after the configuration is saved.

Part 4: Connect to the Alarm Panel manually as well as view/edit connection properties: The Alarm Panel Connections tab shows an IP connection for each alarm panel that has been configured in System Galaxy. The status (connected or disconnected) is displayed (see fig. 11a).

a) Auto-Connect: the Alarm Panel service should automatically connect to the panel once the configuration is saved in the SG Database. The auto-connect option defaults to “on” and can be edited for each individual panel connection from the Service Configuration window (see Sect. 8.3.4).

NOTE: The ability to connect to a panel depends on several things:
- The alarm panel must be properly connection to the SG Communication Server (PC).
- The Alarm Panel must be registered and correctly configured in System Galaxy.
- Both the DBWriter Service and Alarm Panel Service must be running.

b) User can manually connect and disconnect from the alarm panel by right-clicking the connection status and getting a shortcut menu.

NOTE: The short menu also allows user to open the Connection Properties where the settings to automatically connect to panel can be enabled or disabled. User can also edit the Connection Settings and configure Encryption from the Connection Properties screen. See Section 8.3.4 for details.

FIG 11a: Alarm Panel Service screen/Connecting to the Alarm Panel (cropped)

- Connect/Disconnect - user can manually connect/disconnect the selected panel.
- Ping/Telnet – opens a DOS window and executes a ping/telnet command to the IP Address of the selected panel. (Only for panels using TCP/IP connections)
- Properties – opens the Connection Properties screen, allowing user to change the connection settings for the selected panel. See the following section on Managing Connection Properties for details on the properties fields and Setting Encryption.
8.3.4 Managing Properties of the Alarm Panel Connection

User can edit the IP parameters and connection settings from the Connection Properties window. User can also configure the encryption settings from this window.

The parameters in this screen are originally programmed in the Alarm Panel Properties screen and saved in the SG database (Refer to Section 5).

**NOTE: Two important check boxes appear at the bottom of the Connection Properties screen:**

- The “Auto-Connect when service starts” option: When checked the selected alarm panel will be automatically connected whenever the Alarm Panel Service starts.
- The “Auto-reconnect” option: When checked the Alarm Panel Service will automatically attempt reconnect to the selected panel when the panel becomes disconnected.

Also user can access the Encryption Settings from this screen by pressing the [Encryption Settings] button.

When the [Encryption Settings] button is pressed this dialog box opens.

- **key length = 128 (default) ; must be zero if not used.**
- **must specify a key value:** the key value is a 16 digit hex code; must be blank if not used.
8.3.5 How to see and manage the IP connections between services

The TCP/IP Connections tab shows the incoming and outgoing IP connections between GCS Services. The ClientGW Service and the DBWriter Service should each show a connection in this screen. There should only be one Client Gateway connection even if the system has more than one client.

User can manually connect and disconnect from the services by right-clicking the TCP/IP Service Connections screen and getting a shortcut menu.

- **Force Disconnect option**: allows operator to manually disconnect the selected service.
  - The incoming (ClientGW) service should reconnect automatically within 30 to 60 seconds provided it is up and running.
  - The outgoing connection to DB Writer Service can be forced to reconnect using the ‘Connect to Server’ option on the shortcut menu.

- **Connect To Server option**: allows the user to manually connect to the downstream service (in this case the DBWriter). To reconnect manually, you must know the IP address and port number of the downstream service. DBWriter listens on port 4001. Use the NIC card loop-back address (127.0.0.1) if the DBWriter and Alarm Panel service are both running on the same computer (which should be the case).
8.3.6 Log File for GCS Alarm Panel Service

The AP Service creates a log file of connection status messages. This is log of connection attempts between the Service and the Alarm Panel as well as other messages. This text file is stored in the System Galaxy\Log Files folder. The buffer of recent entries is viewable in the GCS Alarm Panel screen on the Status Messages tab.

FIG 13: Alarm Panel Service screen/Connect to Panel statuses (cropped)

NOTE: the debugging option should not be on unless recommended specifically by System Galaxy Technical Support.
9 Getting Events from the Alarm Panel

System Galaxy displays *alarm panel status messages* in the *Alarm Panel Event screen*. If the system is registered for the alarm panel then the *Alarm Panel Event screen* will open when the software opens.

When all the necessary GCS Services are running and the alarm panel is connected to the Alarm Panel service, then System Galaxy can start receiving live events from the alarm panel.

**In the picture below, the operator sees:**
- *Alarm Panel Event screen*, which displays events from the alarm panel, alarm area(s) and alarm point(s).
- *Alarm Panel branch* in the hardware tree.
- Right-clicking an alarm event opens the *command menu*. Operator can send commands to the alarm panel from a command menu.
- Command menus are also available when user right-clicks icons in the hardware tree.

**IMPORTANT:** to reopen the alarm panel event window without restarting System Galaxy – go to the main menu, select View>Alarm Panel Events. If this option is grayed out your event window is already open.

**FIG 14: Alarm Panel Event screen with command menus**

Right-click the *event message* or the *icon* in the hardware tree to get the command menu.
10 Command Menus for the Alarm Panel

Shortcut command menus are available when user right-mouse-clicks the icons from the hardware tree. The alarm panels will be displayed as a branch in the hardware tree. From the Alarm Panel Icon, the operator can expand and see the Alarm Panel and its Areas and Points.

**NOTE:** Alarm Panel commands are also available from the Graphics Screen, Device Status screen and the Alarm Panel Event screen. To get the command menu in the Alarm Panel Event screen, operator must right-click the event message.

**Command Menu options for Panels** allows operator to invoke commands panel-wide (areas and points) and the report includes the panel-level messages.

- Disarm all areas
- Master arm instant
- Master arm delay
- Perimeter instant
- Perimeter delay
- Panel history report (crystal report of Panel level events stored in SG database). Note that only live events are recorded in the database.

**Command Menu options for Areas** allows operator to arm and disarm an area. The options Master arm and Perimeter arm allow user to perform an INSTANT or DELAYED command. Ex: *Instant* will arm instantly; delay will arm after a specified amount of time that is set at the panel

- Disarm area
- Master arm instant
- Master arm delay
- Perimeter instant
- Perimeter delay
- Area history report (crystal report of Area arm and disarm events)

**Command Menu options for Points** allows operator to invoke commands to points.

- Bypass/un-bypass (the selected point) available based on Bypass Allowed checkbox in the Point Property screen
- View Camera (if a DVR and camera are associated with the point
- View Web come (if programmed)
- Report include the status messages from the selected point stored in SG database. Note that only live events are recorded in the database.
11 Device Status for Alarm Panel

System Galaxy supports device status, which includes command menus.

- open the Device Status screen from the main menu: select View > Device Status
- click the [Add New] button and type a descriptive name
- click the Alarm Panel Points tab
- pick the points you wish to create a view for and move them to the INCLUDE list
- click [Apply] and [OK]

Once you have created the view, the Device Status screen will open.

- Not normal /arm alarm = red dot
- Normal / arm = green dot
- Not Normal/Disarm = yellow
- Normal / Disarm = gray dot
- Bypass Point = gray with red-X
- Unknown = gray with question mark

FIG 15: Device Status screen (cropped)
12 Adding Icons for the Graphics screen

**NEW FEATURE** – System Galaxy provides a standard set of icons, and allows the user the ability to import additional icons. These icons are mapped to each of the status conditions in the Alarm Point programming screen. After mapping the status conditions to the desired graphic symbols, the symbols can be dropped onto the Graphics screen.

NOTE: Bitmap (.bmp) icons of any size can be imported. However, these icons are displayed as 32x32 bit icons when they are dropped onto the Graphics screen.

To add new graphics do the following:

- Copy new bitmap file(s) into the icon directory (verify and use the path that is set in Multimedia tab in the Workstation Options screen – the path is set in the ‘Specify location for the graphic icon/bitmap files’)
- From the main menu pick the Configure>Hardware>Graphic Symbol option.
- Click the [Add New] button and type a Name
  - Or click [Edit] and select an existing name if you wish to change an existing icon
- Select a bitmap file or browse to a file (must be a bitmap file)
- Select the [Apply] button to save changes

FIG 16: Graphics Symbols screen
13 Placing Alarm Points on the Graphics screen

The System Galaxy Graphics screen is typically opened to a floor plan image and icons are dropped onto the Graphics screen (i.e. floor plan) in the locations that represent the actual alarm points. Once the icons are placed on the Graphic screen, the color graphic they are mapped to will be displayed when the state/condition of the alarm point changes.

The process for setting up icons is outlined below:

1. A graphic icon is mapped to each status condition for every alarm point in the Alarm Point Property screen - Graphics Symbols tab. See instructions for mapping icons in the Adding an Alarm Panel Point section.

2. The graphic icons are dropped onto the floor plan in the Graphics screen. See this section on Placing Icons in the Graphic Screen for details. The state of the graphic follows the status/condition of the alarm point (based on mapping of symbols in the Alarm Point Property screen).

How to get the graphic icon on the Graphics screen:
- Open the Graphic screen by selecting the View>Graphic option from the main SG menu; then select and open the desired floor plan or blueprint image – the graphic will open in the Graphic screen.
- Expand the Alarm Panel branch in the Hardware Tree until you can see the points.
- Left-click the alarm point and hold the left-mouse button down while dragging it over to the floor plan.
- Release the mouse button on the desired location of the floor plan - you should see a shortcut menu with the option ‘Drop Here’.
- Click the ‘Drop Here’ option to place the icon on the floor plan; the icon will display a checked border to allow you to move and resize the icon as needed.
- Right-click the icon and deselect the move option once the size and location are correct. Now the icon will display the color graphic that you assigned for the current status condition. If the icon does not show the current status condition, refresh the graphic screen by closing and reopening it.

FIG 17: System Galaxy Graphic screen with icons
14 Crystal Reports for Alarm Panel Events

Crystal Reports are available in System Galaxy for the Alarm Panel. The report content depends on which report is chosen. NOTE THAT THE ALARM PANEL DOES NOT RETRANSMIT OFFLINE EVENTS TO THE SG DATABASE. Therefore, the reports only include the “live” status conditions received by System Galaxy when the Alarm Panel is properly connected.

To get the Alarm Acknowledgements report, select the View>Reports>Crystal Reports>Alarm Acknowledgements from the SG main menu.

Status Reports are available for the Alarm Panel, Alarm Areas and Alarm Points. These reports are opened from the command menu.

Command menus are available from the following screens or places:

- status event message for the panel/area/point in the Alarm Panel Event screen
- alarm panel/area/point icon in the Hardware Tree
- alarm point icons in the Graphics Alarm screen
- alarm points in the Device Status screen

See Section 10 for the list of command menus.

Right-clicking a status, event, or icon that is associated with an alarm panel or area or point will display the command menu for that object. Selecting the Status Report option from the command menu will open the report for the selected area or point.

NOTE: All crystal reports open to a separate window. Operator can view or print the report from the crystal report window.

IMPORTANT: if the report looks small (like a badge), reset your default printer back to a regular line printer instead of a badging printer. To reset the default printer, click the Windows® [Start] button and select the Settings>Printers (or Settings>Control Panel and open the Printers window). Once the Printers window is open, user can right-click the desired printer icon and choose the ‘Set as default printer’ option. A black dot with a checkmark will appear on the printer icon that is set for the default printer. Return to System Galaxy and re-open the report.
15 Managing User Codes for Alarm Panels

System Galaxy allows operator to set up and manage user codes for the alarm panel. Operator can also assign user codes to cardholders in System Galaxy.

15.1 Managing Alarm Panel User Codes

Managing user codes is done in the Alarm Panel User Codes screen. This feature allows the System Galaxy operator to retrieve available IDs from the alarm panel and then add the user code. The code is sent down to the alarm panel. This user code is also stored in the SG database and is available to be assigned to cardholders.

To set up user codes do the following:

- Open the Alarm Panel User Codes screen from the main menu: select Configure>Hardware>Alarm Panels> Alarm Panel User Codes
- Select an Alarm Panel and click the [Add New] button
- Click the [Get Available User ID] button
- Type in a user code (6 digits)
- Click the [Apply] button to save and send changes to the alarm panel and SG database

WARNING: if operator chooses an ID that is already in use at the alarm panel, it will be overwritten at the alarm panel. It is always recommended to use the [Get Available User ID] button to retrieve an unused ID from the alarm panel.

FIG 18: Alarm Panel User Code configuration screen
15.2 Assigning Alarm Panel User Codes to Cardholders

System Galaxy allows the operator to manage user codes for the Cardholder. This is an administrative feature and only one code per cardholder can be configured. To set the user codes see section 15.1.

The Alarm Panel User Codes tab in Cardholder screen allows user to associate an alarm panel user code with the cardholder. The user codes are added to the System Galaxy database in the Alarm Panel User Codes Property screen. Once the user code is set up in the SG database it can be picked from the User ID droplist in the Cardholder screen.

- Open the Cardholder screen (Configure>Cards>Cardholders)

  or click the Cardholder button on the toolbar

- Choose the desired Cardholder from the droplist
- Click the [Edit] button
- Select the Alarm Panel User Code tab
- Choose the desired alarm panel from the droplist
- Pick the desired code from the droplist

FIG 19: Cardholder programming screen – Alarm Panel User Codes tab